Page 1 of 1

Compare by "Content" not working for large files

Posted: Sat Dec 13, 2008 1:44 pm
by LanaiLizard
It is almost like the Compare by "Content" feature only compares the two files (if they are large, as in 1GB-2GB in size) up to a point and then assumes the remainder of the file is equal as well.

I have two large files that are not equal but the same for maybe several hundred MBytes of their 1.2GB size. Synchronize It V3.4.0.1640 and the beta V3.4.0.1644 in "compatibility" mode both say the two files are equal when I do a Preview using Compare by "Content" when they should have been flagged as different.

Posted: Mon Dec 15, 2008 6:45 am
by grigsoft
Thank you for your report! Are your files in plain text format, or binary? Also, did you enable smart files comparison for them?

Posted: Mon Dec 15, 2008 9:21 am
by LanaiLizard
The files are binary and smart files comparison is not checked.

I must add another symptom that may be related to this but the opposite result. I have a 7.5GB file that I copied to another system and compared them across the network as being the same via the DOS FC command with the "/b" option.

But when I use Synchronize It with the Compare by "Content" option it immediately (no time to read any significant part, if any, of the two 7.5GB files) comes back and wants to copy this file from the source to the target as if they were NOT equal even though they are equal.

The reason these two cases may be similiar is for some reason the comparison appears to be aborting early in both cases. The first time maybe giving up before encountering different bytes in the two files and the second time maybe giving up immediately before comparing anything and assuming the files are different.

Note that this issue may or may not be related to the posting I did in two other threads thinking there was a problem when I upgraded from V3.1 to V3.4. Apparently, the issue I raised in those posting with the network connection being destroyed during a synch operation may actually be outside Synchronize It with my suspicion being on some Microsoft SMB network security fixes which I applied about the same time I upgraded to V3.4 and which all my problems started.

The other two threads are noted below:

"Delayed Write Error":

"Losing network connection during Synch operation":

If the issues are related to the Microsoft fixes I have not noticed any issues outside of using Synchronize It but of course I probably don't have another app that is stressing the network connection as much either.

Hope this helps,

Posted: Thu May 07, 2009 9:55 am
by LanaiLizard
I'm still not sure what is going on here. This is such an ellusive problem but now I have another repeatable failure I can report.

I have a very large (over 4.4GB) CD image file (.nrg file). The master copy is on a Win2000 system and a backup copy is on a Windows Home Server system.

If I use the DOS "fc" command to compare the files they appear exactly the same as I would expect. For example "fc c:\test\file.nrg z:\test\file.nrg /b" where drive z: is mapped to the Windows Home Server drive come back with no differences.

Now if I run Synchronize It! V3.4.1639 with "Compare by" set to "content" on the "test" directory the two files come back as being different. Other files in this same directory, even one 3.8GB in size, compare correctly as being equal but not this 4.4GB file.

If I run Synchronize It! with "Compare by" set to "Date + Size" everything compares as being the same as you would expect.

Is there some threshold I've crossed in file size that would cause the comparison to report a difference when there are no differences? Oddly, I had the opposite problem I had before, comparing the same when they were different.

I also tried the latest patch V3.4.1653 and turned on "compatibility" mode for drive Z (the networked drive) and I get the same results as with V3.4.1639.

Any ideas?


Posted: Thu May 07, 2009 10:36 pm
by TonHu
Might there be a wrap-around bug/quirk on the 4 GB boundery?


Posted: Fri May 08, 2009 2:29 pm
by grigsoft
Normally there shouldn't be any problems with over 4GB size (if you are using latest version), but I will check that again. Thank you for your report!

Posted: Mon May 11, 2009 1:22 pm
by grigsoft
I have to admit that there is a problem with content comparison of files longer then 4GB. I will try to fix it shortly.

Posted: Sat May 23, 2009 5:36 am
by grigsoft
Comparing large files should work now.

Posted: Sat Aug 08, 2009 12:09 pm
by LanaiLizard
Thanks! The update (now V3.4.1677) did fix my >4GB file compare problem. Sorry it took so long for me to be able to post this feedback.